ITSM 7.5 SLM Status throws HTTP 500: exception - Bad version number in .class file

Saturday, December 26, 2009

Again with BMC ITSM 7.5 I faced a new issue.

From the incident management console, if you open an incident to view it, then under SLM Status section, instead of showing a graphic, it is pulling back a web error –

HTTP 500:
exception

javax.servlet.ServletException: Servlet execution threw an exception


root cause

java.lang.UnsupportedClassVersionError: Bad version number in .class file
java.lang.ClassLoader.defineClass1(Native Method)
java.lang.ClassLoader.defineClass(ClassLoader.java:620)


This issue happens because the java version used to build the module was higher that what i am using. The version i am using is java 1.5.

As a solution for this there is a Hotfix available with BMC. Log into BMC Support Site and get the Hotfix for java 1.5. It solved the issue.

Followers

 

2009 ·Techy Freak by TNB